Subject: [PATCH links] Make save counter more clear. Also looks a little nicer.

From: Peter Sanchez <[email-masked]>
Date: Thu, 17 Apr 2025 08:05:04 -0600

Changelog-updated: Link counter is more more clear and imho aesthetic
---
 static/css/style.css     | 3 +++
 templates/link_list.html | 6 +++---
 2 files changed, 6 insertions(+), 3 deletions(-)

diff --git a/static/css/style.css b/static/css/style.css
index 3630636..36ba467 100644
--- a/static/css/style.css
+++ b/static/css/style.css
@@ -186,6 +186,9 @@ footer blockquote {
   font-size: 1.25em !important;
   /*font-weight: bold;*/
 }
+.tag-popular {
+  margin-left: 0.5rem;
+}
 .link-tag__side {
   border: 1px solid;
   letter-spacing: .5px;
diff --git a/templates/link_list.html b/templates/link_list.html
index e0d7d7f..fae218b 100644
--- a/templates/link_list.html
+++ b/templates/link_list.html
@@ -99,10 +99,10 @@
           {{end}}
           <h3 class="is-marginless mr-1">
             <a class="text-dark" href="{{.URL}}" target="_blank">{{truncate .Title 60}}</a>
+            {{if $.isPopular}}
+	      <span class="button outline primary tag tag-popular is-small">{{ .Counter }}</span>
+            {{end}}
           </h3>
-          {{if $.isPopular}}
-          <small class="text-grey counter-number"><strong>{{.Counter}}</strong></small>
-          {{end}}
           {{if $.isOrgLink}}
             {{if eq .UserID $.currentUserID}}
                 <!-- Read/Unread -->
-- 
2.47.2

---

From: "Peter Sanchez" <[email-masked]>
Date: Thu, 17 Apr 2025 08:19:10 -0600

Applied.

To [email-masked]:~netlandish/links
   26fba77..25bdb98  master -> master