Subject: [PATCH links] Update gobwebs-graphql to support max in memory buffer size limitations for graphql file uploads. Update config.example.ini to show the option.

From: Peter Sanchez <[email-masked]>
Date: Fri, 18 Jul 2025 06:09:15 -0600

---
 config.example.ini | 1 +
 go.mod             | 2 +-
 go.sum             | 4 ++--
 3 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/config.example.ini b/config.example.ini
index c26190a..98a7864 100644
--- a/config.example.ini
+++ b/config.example.ini
@@ -119,6 +119,7 @@ entropy=Entropy value
 [graphql]
 max-complexity=250
 max-upload-size=10737418
+max-memory-size=33554432
 schema-file=/path/to/schema.graphqls
 default-query-file=/path/to/default_query.graphql
 
diff --git a/go.mod b/go.mod
index 37c0e68..77cbe32 100644
--- a/go.mod
+++ b/go.mod
@@ -31,7 +31,7 @@ require (
 	netlandish.com/x/gobwebs v0.1.3
 	netlandish.com/x/gobwebs-auditlog v0.2.1
 	netlandish.com/x/gobwebs-formguard v0.2.1
-	netlandish.com/x/gobwebs-graphql v0.2.1
+	netlandish.com/x/gobwebs-graphql v0.2.2
 	netlandish.com/x/gobwebs-oauth2 v0.2.1
 	netlandish.com/x/gobwebs-ses-feedback v0.2.1
 	petersanchez.com/x/carrier v0.2.3
diff --git a/go.sum b/go.sum
index 0c034e3..a98866a 100644
--- a/go.sum
+++ b/go.sum
@@ -2586,8 +2586,8 @@ netlandish.com/x/gobwebs-auditlog v0.2.1 h1:3wdULHX3qtWF7qu3vWDMznEoF0Vx/a5xk6S7
 netlandish.com/x/gobwebs-auditlog v0.2.1/go.mod h1:67Wc5fWo3g0jnviqt1fSCzk+oRxQFE9gLTgJ8IaSRrw=
 netlandish.com/x/gobwebs-formguard v0.2.1 h1:h2OThT9fnntfPrC0OoB3U+23urmcGa17SKHfPzU8dDg=
 netlandish.com/x/gobwebs-formguard v0.2.1/go.mod h1:GHiN6/0phQ8gOu1acrifbwG8P6jMJ6Ij2vJlvHHm+1w=
-netlandish.com/x/gobwebs-graphql v0.2.1 h1:uEWyaTtHsZKLWYlXNtQd1twhI9cBeL0WVtDOVnH5aAw=
-netlandish.com/x/gobwebs-graphql v0.2.1/go.mod h1:E9Xk+dGllPWsIBEE+VyzhedX7kwsygdeOHwxJdJxoYw=
+netlandish.com/x/gobwebs-graphql v0.2.2 h1:KzHHFkHSJtV2rGqMr2QpnBlI4STTijDgAouliYAzTpY=
+netlandish.com/x/gobwebs-graphql v0.2.2/go.mod h1:E9Xk+dGllPWsIBEE+VyzhedX7kwsygdeOHwxJdJxoYw=
 netlandish.com/x/gobwebs-oauth2 v0.2.1 h1:j/zU13PY0GavaSNnEy+f6ExbkamWBIm4mUIPaQ8gE78=
 netlandish.com/x/gobwebs-oauth2 v0.2.1/go.mod h1:ssioqpjdRNwqFI7Da46A1K08szJzOZaEgIYoTPPYaXo=
 netlandish.com/x/gobwebs-ses-feedback v0.2.1 h1:9BLmmsPmmCkb7DpLzJgBrhibaJOW3NQfPnSlkpjWSnY=
-- 
2.49.0

---

From: "Peter Sanchez" <[email-masked]>
Date: Fri, 18 Jul 2025 06:12:00 -0600

Applied.

To [email-masked]:~netlandish/links
   af4a4e4..943c898  master -> master