Subject: [PATCH links] Updating each service to use DBI interface

From: Peter Sanchez <[email-masked]>
Date: Sun, 10 Aug 2025 09:27:40 -0600

---
 cmd/api/main.go     | 2 +-
 cmd/domains/main.go | 2 +-
 cmd/links/main.go   | 2 +-
 cmd/list/main.go    | 2 +-
 cmd/short/main.go   | 2 +-
 5 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/cmd/api/main.go b/cmd/api/main.go
index 8e935e1..ab6ee51 100644
--- a/cmd/api/main.go
+++ b/cmd/api/main.go
@@ -129,7 +129,7 @@ func run() error {
 		SetWorkerPoolFunc(cmd.GetWorkerPoolCount).
 		WithQueues(eq, wq).
 		WithMiddleware(
-			database.Middleware(db),
+			database.DBIMiddleware(db),
 			core.RemoteIPMiddleware,
 			loaders.Middleware(),
 			core.TimezoneContext(),
diff --git a/cmd/domains/main.go b/cmd/domains/main.go
index 5cfa63d..75508f8 100644
--- a/cmd/domains/main.go
+++ b/cmd/domains/main.go
@@ -77,7 +77,7 @@ func run() error {
 		WithAppInfo("links-domains", Version).
 		DefaultMiddlewareWithConfig(mwConf).
 		WithMiddleware(
-			database.Middleware(db),
+			database.DBIMiddleware(db),
 			core.TimezoneContext(),
 			core.CORSReadOnlyMiddleware,
 		)
diff --git a/cmd/links/main.go b/cmd/links/main.go
index b9b9524..8defffc 100644
--- a/cmd/links/main.go
+++ b/cmd/links/main.go
@@ -225,7 +225,7 @@ func run() error {
 		SetWorkerPoolFunc(cmd.GetWorkerPoolCount).
 		WithQueues(eq, wq, wqi, imq).
 		WithMiddleware(
-			database.Middleware(db),
+			database.DBIMiddleware(db),
 			core.RemoteIPMiddleware,
 			core.TimezoneContext(),
 			crypto.Middleware(entropy),
diff --git a/cmd/list/main.go b/cmd/list/main.go
index cdd9253..56f535e 100644
--- a/cmd/list/main.go
+++ b/cmd/list/main.go
@@ -91,7 +91,7 @@ func run() error {
 		SetWorkerPoolFunc(cmd.GetWorkerPoolCount).
 		WithQueues(eq, wq).
 		WithMiddleware(
-			database.Middleware(db),
+			database.DBIMiddleware(db),
 			core.RemoteIPMiddleware,
 			core.TimezoneContext(),
 			crypto.Middleware(entropy),
diff --git a/cmd/short/main.go b/cmd/short/main.go
index e5b6276..01bcfb7 100644
--- a/cmd/short/main.go
+++ b/cmd/short/main.go
@@ -89,7 +89,7 @@ func run() error {
 		SetWorkerPoolFunc(cmd.GetWorkerPoolCount).
 		WithQueues(eq, wq).
 		WithMiddleware(
-			database.Middleware(db),
+			database.DBIMiddleware(db),
 			core.RemoteIPMiddleware,
 			core.TimezoneContext(),
 			crypto.Middleware(entropy),
-- 
2.49.1

---

From: "Peter Sanchez" <[email-masked]>
Date: Sun, 10 Aug 2025 09:31:38 -0600

Applied.

To [email-masked]:~netlandish/links
   6973ac0..a440a0d  master -> master