Subject: [PATCH links] Another gobwebs bump to address bug found after last bump. Issue was in the gobwebs DBI interface but is now resolved.

From: Peter Sanchez <[email-masked]>
Date: Sun, 10 Aug 2025 13:05:01 -0600

---
 config.example.ini |  2 +-
 go.mod             | 12 ++++++------
 go.sum             | 24 ++++++++++++------------
 3 files changed, 19 insertions(+), 19 deletions(-)

diff --git a/config.example.ini b/config.example.ini
index 98a7864..bc0e4fb 100644
--- a/config.example.ini
+++ b/config.example.ini
@@ -50,7 +50,7 @@ domain=127.0.0.1:8000
 # postgresql://[user[:password]@][netloc][:port][/dbname][?param1=value1&...]
 # If host is unix file, use "host" qs variable
 connection-string = postgresql://psanchez@/links?host=/var/run/postgresql
-max-connections = 2
+max-connections = 10
 
 # More complicated strings can be passed in qs vars as well. For instance, 
 # if your password contains the ":" or "@" chars, it should go in the qs
diff --git a/go.mod b/go.mod
index e70f2c7..92eaa23 100644
--- a/go.mod
+++ b/go.mod
@@ -30,12 +30,12 @@ require (
 	golang.org/x/text v0.27.0
 	golang.org/x/time v0.8.0
 	hg.code.netlandish.com/~netlandish/sendygo v0.0.0-20230124192435-bbf347776232
-	netlandish.com/x/gobwebs v0.1.5
-	netlandish.com/x/gobwebs-auditlog v0.2.2
-	netlandish.com/x/gobwebs-formguard v0.2.3
-	netlandish.com/x/gobwebs-graphql v0.2.3
-	netlandish.com/x/gobwebs-oauth2 v0.2.2
-	netlandish.com/x/gobwebs-ses-feedback v0.2.3
+	netlandish.com/x/gobwebs v0.1.6
+	netlandish.com/x/gobwebs-auditlog v0.2.3
+	netlandish.com/x/gobwebs-formguard v0.2.4
+	netlandish.com/x/gobwebs-graphql v0.2.4
+	netlandish.com/x/gobwebs-oauth2 v0.2.3
+	netlandish.com/x/gobwebs-ses-feedback v0.2.4
 	petersanchez.com/x/carrier v0.2.3
 	petersanchez.com/x/carrier/ses v0.0.0-20250114214955-7f5d9b835a85
 	petersanchez.com/x/carrier/smtp v0.0.0-20250114214955-7f5d9b835a85
diff --git a/go.sum b/go.sum
index a0f957a..ddd92c0 100644
--- a/go.sum
+++ b/go.sum
@@ -2578,18 +2578,18 @@ modernc.org/z v1.0.1-0.20210308123920-1f282aa71362/go.mod h1:8/SRk5C/HgiQWCgXdfp
 modernc.org/z v1.0.1/go.mod h1:8/SRk5C/HgiQWCgXdfpb+1RvhORdkz5sw72d3jjtyqA=
 modernc.org/z v1.2.20/go.mod h1:zU9FiF4PbHdOTUxw+IF8j7ArBMRPsHgq10uVPt6xTzo=
 modernc.org/zappy v1.0.0/go.mod h1:hHe+oGahLVII/aTTyWK/b53VDHMAGCBYYeZ9sn83HC4=
-netlandish.com/x/gobwebs v0.1.5 h1:ZYm/zVFOr/D9lRhE4zXWTv27BwDEHP8pPaZafTiPxDo=
-netlandish.com/x/gobwebs v0.1.5/go.mod h1:RAf0VNiujzXen/pu0k6yyhvPWMgCY9tKD7ftXrkT53E=
-netlandish.com/x/gobwebs-auditlog v0.2.2 h1:BqDXkBnK0P2rKqQxliCP6r33Fv1cMUxFB/W65L/LCT0=
-netlandish.com/x/gobwebs-auditlog v0.2.2/go.mod h1:BP+hVVNdsTNgCUaM1JfwnLNsdGwCoyBGxXhDrS8hPww=
-netlandish.com/x/gobwebs-formguard v0.2.3 h1:uXWVGLu7fslk4qGw7ZuVJQcplyh/HOf8kmmuReIlarE=
-netlandish.com/x/gobwebs-formguard v0.2.3/go.mod h1:0nK6mnyCATC32tanPrG5SrXj/Kbsmu4jRLt5JWtWURA=
-netlandish.com/x/gobwebs-graphql v0.2.3 h1:0rjL7YdvWdCvmwT0iofO4PAJ0GVbHum+pAmtfNNp51U=
-netlandish.com/x/gobwebs-graphql v0.2.3/go.mod h1:UDV59+6AOffuJE85u9zRYf6ngPUm6ebxNtb4HL8XaDU=
-netlandish.com/x/gobwebs-oauth2 v0.2.2 h1:Q4tQpCH6bJqrkk8ozmnG6WsykED2BaFXt9VLmJQryHc=
-netlandish.com/x/gobwebs-oauth2 v0.2.2/go.mod h1:Sbi9h2E+5JrCr+vaB+8pmFgQNgdCyPqdvB4cqLXM8GM=
-netlandish.com/x/gobwebs-ses-feedback v0.2.3 h1:yW+1m+TFT6i93NlEoZaPJI1G4ZWBfDEDZGXHsspbC5g=
-netlandish.com/x/gobwebs-ses-feedback v0.2.3/go.mod h1:6iKSktXc1oNHTWQZKY/TyXIj/7uCmLoI7/XK8CKqjsw=
+netlandish.com/x/gobwebs v0.1.6 h1:/fXVU2hoS6FyIk/Refl1FqxCGJxjcCvCybnrxr2JYlI=
+netlandish.com/x/gobwebs v0.1.6/go.mod h1:RAf0VNiujzXen/pu0k6yyhvPWMgCY9tKD7ftXrkT53E=
+netlandish.com/x/gobwebs-auditlog v0.2.3 h1:U9Kcbacy+6gUbm2wwXUKg4q7RpbRwHgaLXebQWiYlXk=
+netlandish.com/x/gobwebs-auditlog v0.2.3/go.mod h1:E5K6BDkD6BTgwGDz2GWOE/h/PfKuyswLDnhU1gDWNPQ=
+netlandish.com/x/gobwebs-formguard v0.2.4 h1:YkLudnPrwr9k/giURyohnjlfbuC+Ws8hnrrU+MY8vUc=
+netlandish.com/x/gobwebs-formguard v0.2.4/go.mod h1:0UZ/lWNAqHCwDYotp2WlX0XgfsF8PfV8XBr29kSJmP8=
+netlandish.com/x/gobwebs-graphql v0.2.4 h1:BWuWiTkTVJNdBITV36r42w7Uh+6HGgZvxOj3+XICsF4=
+netlandish.com/x/gobwebs-graphql v0.2.4/go.mod h1:vegE1Sb69L19qk/Urx7HWFhJ3FCjZZ5e0n5PlXDE1Qc=
+netlandish.com/x/gobwebs-oauth2 v0.2.3 h1:gtxVwa/TFquvPm7sL9CYPN6qF9dayovK09bhv8s/bkE=
+netlandish.com/x/gobwebs-oauth2 v0.2.3/go.mod h1:OXmkl1iL3MMy4CzdtAc9oOQbX/2kbR8/2t2GCahHBho=
+netlandish.com/x/gobwebs-ses-feedback v0.2.4 h1:0jSGszEAKxKOJrhiO/vQuuY6lQv7fcsP4s6Iw5EcOJk=
+netlandish.com/x/gobwebs-ses-feedback v0.2.4/go.mod h1:s7BCQ4lYPLdvzDuDvZmQn+7IHKsHNIkecs4jcjoZ0ZM=
 petersanchez.com/x/carrier v0.2.3 h1:6ScWG2HVFqeqafQp2D9kChNdXYkou4rduzppc3SDYMg=
 petersanchez.com/x/carrier v0.2.3/go.mod h1:GLiDI9OThDmruufk/VHlR6Ihvq/hIJQyA5beU6AFNYk=
 petersanchez.com/x/carrier/ses v0.0.0-20250114214955-7f5d9b835a85 h1:yy81/rrGdI+YWuTvv7JPvVnY104/g10vnloBnKxVAHk=
-- 
2.49.1

---

From: "Peter Sanchez" <[email-masked]>
Date: Sun, 10 Aug 2025 13:07:17 -0600

Applied.

To [email-masked]:~netlandish/links
   a440a0d..fc98b6e  master -> master